Error setting up jekyll in ubuntu

Today i was trying to setup jekyll in ubuntu. Installation as such as is not bad. install rubygems, ruby-dev, after that 

gem install jekyll (which was originally stated by the blog).

Then run the command, 

jekyll new myblog,

the following error is reported

> $ jekyll new myblog
/var/lib/gems/1.8/gems/commander-4.1.6/lib/commander/runner.rb:385:in `require_program': program version required (Commander::Runner::CommandError)
from /var/lib/gems/1.8/gems/commander-4.1.6/lib/commander/runner.rb:384:in `each'
from /var/lib/gems/1.8/gems/commander-4.1.6/lib/commander/runner.rb:384:in `require_program'
from /var/lib/gems/1.8/gems/commander-4.1.6/lib/commander/runner.rb:52:in `run!'
from /var/lib/gems/1.8/gems/commander-4.1.6/lib/commander/delegates.rb:8:in `run!'
from /var/lib/gems/1.8/gems/commander-4.1.6/lib/commander/import.rb:10
from /usr/local/bin/jekyll:19
/usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require': no such file to load -- json (LoadError)
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /var/lib/gems/1.8/gems/jekyll-1.4.3/bin/../lib/jekyll/filters.rb:2
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /var/lib/gems/1.8/gems/jekyll-1.4.3/bin/../lib/jekyll.rb:44
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /var/lib/gems/1.8/gems/jekyll-1.4.3/bin/jekyll:7
from /usr/local/bin/jekyll:19:in `load'
from /usr/local/bin/jekyll:19

To fix this error, run the following commands

gem install json

gem install commander